Mohammadreza Soleimani 855 روز پیش verl
بازدید 1157 بدون دیدگاه

SSH چیست – چگونگی پیاده سازی

SSH چیست – چگونگی پیاده سازی(سیسکو SSH یا Secure Socket Shell یک پروتکل شبکه ای است که به کاربران به ویژه مدیران سیستم ( Administrator ) راهی امن برای دسترسی به کامپیوتر یا تجهیزات شبکه از طریق بستر نا امن اینترنت را می دهد. Secure Shell احراز هویت به واسطه رمز عبور قوی ( Password Authentication ) و احراز هویت کلید عمومی ( Public key Authentication ) و همچنین ارتباطات رمزنگاری شده بین دو کامپیوتر یا تجهیزات شبکه متصل به شبکه نا امن اینترنت را فراهم می نماید. علاوه بر ارائه رمزنگاری قوی، SSH به طور گسترده توسط مدیران شبکه برای مدیریت سیستم ها و برنامه های کاربردی از راه دور مورد استفاده قرار می گیرد و آن ها را قادر می سازد تا از طریق شبکه به کامپیوتر یا تجهیزات شبکه ای دیگری وارد شوند و دستورات مد نظر خود را از راه دور اجرا نمایند. SSH از مدل Server و Client استفاده می نماید که Client به واسطه یک برنامه ارتباط SSH را با Server مد نظر خود که می تواند یک کامپیوتر یا یکی از تجهیزات شبکه که از این قابلیت پشتیبانی می نماید، باشد. یک سرور SSH به طور پیش فرض به درخواست ها با پروتکل TCP و پورت استاندارد 22 پاسخ می دهد.

 

SSH چیست – چگونگی پیاده سازی

فهرست مطالب

  1. SSH چیست – چگونگی پیاده سازی
    1. SSH چگونه کار میکند؟
    2. تنظیمات سایت 1
    3. تنظیمات سایت 2

 

SSH چگونه کار میکند؟

SSH جایگزینی بسیار کاربردی برای برنامه های شبیه سازی ترمینال به صورت نا امن نظیر Telnet می باشد. SSH دقیقا همان قابلیت Terminal Session برای دسترسی به سیستم ها از راه دور را در اختیار ما قرار می دهد. اساسی ترین کاربرد SSH اتصال به یک میزبان ( Host ) از راه دوراست. عملکرد SSH مشابه Telnet می باشد با این تفاوت اصلی که پروتکل SSH از رمزنگاری کلید عمومی ( Public key ) برای احراز هویت نقاط پایانی ( Endpoint ) هنگام برقراری یک ترمینال و همچنین رمزنگاری دستورات اجرا شده در تمام مدت برقرای ترمینال استفاده می نماید.

 


 


Router> enable
Router# configure terminal
Router(config)# hostname R1
R1(config)# enable secret SECRET
R1(config)# username USER secret SECRET
R1(config)# crypto key generate rsa modulus 768
R1(config)# ip ssh version 2
R1(config)# ip domain name NAME
R1(config)# line vty 0 4
R1(config-line)# login local
R1(config-line)# transport input ssh


 

 

سناریو: به عنوان ادمین قرار است به شما وظیفه تنظیمات  SSHروی روتر سایت 1 محول شود به طوری که از روتر سایت 2 امکان برقراری ارتباط SSH به صورت ریموت با سایت 1 فراهم گردد:

تنظیمات زیر در سایت 1 از شما باید درخواست شده:

  1. تغییر نام دستگاه ( hostname ) از حالت پیش فرض به Site1
  2. تنظیم Secret برای مود Global ( Cisco!23 )
  3. ایجاد کاربر محلی ( Local User ) در روتر مقصد ( Site1 ) برای احراز هویت با نام test و پسورد Cisco!23
  4. اعمال IP روی interface مورد نظر 192.168.1.1/24
  5. انجام کلیه تنظیمات SSH – Site1 فقط از طریق SSH قابل دسترس باشد و سایر ارتباطات مثل Telnet غیر فعال باشد

 

تنظیمات زیر در سایت 2 (Site2  ) از شما درخواست شده:

 

  1. اعمال IP روی interface مورد نظر 168.1.2/24
  2. برقراری ارتباط از Site2 به سمت Site1 توسط SSH

 


 

Site1:
Router> enable
Router# configure terminal
Router(config)# hostname site1
Router(config)# enable secret Cisco!23
Site1(config)# username test secret Cisco!23
Site1(config)# interface gig 0/0
Site1(config-if)# ip address 192.168.1.1 255.255.255.0
Site1(config-if)# no shutdown
Site1(config-if)# exit
Site1(config)# crypto key generate rsa modulus 768
Site1(config)# ip ssh version 2
Site1(config)# ip domain name MyDomain
Site1(config)# line vty 0 4
Site1(config-line)# login local
Site1(config-line)# transport input ssh


Site2:
Router> enable
Router# configure terminal
Router(config)# hostname site2
Site2(config)# interface gig 0/0
Site2(config-if)# ip address 192.168.1.1 255.255.255.0
Site2(config-if)# no shutdown
Site2(config-if)# end

SSH Connection From Site2
Site2# ssh -l test 192.168.1.1
Password: Cisco!23

Site1>


سیسکو – Cisco

نظرات کاربران

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

Select the fields to be shown. Others will be hidden. Drag and drop to rearrange the order.
  • Image
  • SKU
  • Rating
  • Price
  • Stock
  • Availability
  • Add to cart
  • Description
  • Content
  • Weight
  • Dimensions
  • Additional information
  • Attributes
  • Custom attributes
  • Custom fields
Click outside to hide the comparison bar
Compare
Compare ×
Let's Compare! Continue shopping