Mohammadreza Soleimani 344 روز پیش verl
بازدید 540 بدون دیدگاه

احراز هویت در EIGRP

احراز هویت در EIGRP،  در شبکه هایی با مقیاس گسترده ممکن است افراد با اهدافی خاص، قصد ایجاد همسایگی و دسترسی به شبکه با استفاده از پروتکل های مسیریابی را داشته باشند. این افراد ممکن است با ایجاد همسایگی بین روتر های سازمان مسیر های نادرستی را در سطح شبکه Advertise و منتشر نمایند. به منظور جلوگیری از انجام چنین فعالیت هایی در شبکه می توان از احراز هویت بین روتر هایی که در EIGRP نقش دارند استفاده نمود. در ابتدا به مرور بر EIGRP خواهیم پرداخت.

 

احراز هویت در EIGRP

فهرست مطالب

  1. مروری بر EIGRP
  2. احراز هویت در EIGRP
  3. روش های پیاده سازی EIGRP
  4. پیکربندی احراز هویت

 

مروری بر EIGRP

EIGRP ( Enhanced Interior Gateway Routing Protocol ) یک پروتکل مسیریابی بردار فاصله ( Distance Vector ) است که بر اساس اصول پروتکل مسیریابی IGP می باشد. ویژگی منحصر به فرد این پروتکل توان عملیاتی بالا و سرعت در نرخ همگرایی می باشد.

EIGRP از از معیارهایی مانند پهنای باند، Load و تأخیرها برای محاسبه کوتاه ترین مسیر بهینه شبکه استفاده می نماید. این پروتکل از نظر تکنولوژیکی از مسیریابی مبتنی بر بردار فاصله پیشرفته تری استفاده می نماید. جهت تبادل اطلاعات با استفاده از EIGRP ابتدا روترها باید با  EIGRP  همسایه شوند، سپس EIGRP از آدرس چند پخشی ( Multicast ) برای به اشتراک گذاری اطلاعات استفاده می نماید.

منطق زیرساختی EIGRP مبتنی بر مفهوم یک سیستم خودمختار ( autonomous ) است. در چنین شرایطی روتر های همسایه با شماره سیستم یکسانی پیکربندی می گردند. EIGRP یک پروتکل مسیریابی پویا است که برای اتصال شبکه های مختلف بین روتر ها پیکربندی می گردد. EIGRP جهت ارسال اطلاعات به روتر های همسایه تنها به روز رسانی ها را ارسال می نماید که این مکانیزم تاثیر بسیار مثبتی در حجم پردازش روتر ها خواهد داشت و همچنین نرخ ارسال اطلاعات را پایین تر خواهد آورد.

EIGRP یک پروتکل ترکیبی است که از مسیریابی بدون کلاس ( Classless ) و همچنین خلاصه سازی خودکار و دستی ( summarization ) در اینترفیسی که در EIGRP فعال است، پشتیبانی می نماید. احراز هویت در EIGRP با استفاده از MD5 انجام می گیرد و حداکثر Hop-count تعداد 255 روتر می باشد. همچنین امکان استفاده از مکانیزم تقسیم بار برابر ( equal load-balance ) و تقسیم بار نا برابر ( unequal load-balance ) در EIGRP فراهم می باشد. جهت مطالعه مطالب تکمیلی در خصوص پروتکل مسیریابی EIGRP مقاله (راه اندازی EIGRP در روتر سیسکو) در دسترس می باشد.

 

احراز هویت در EIGRP

احراز هویت در EIGRP از دسترسی تجهیزات غیر مجاز به پروتکل مسیریابی جلوگیری می نماید و به این تجهیزات اجازه برقراری همسایگی با روتر های شبکه را نخواهد داد. همانطور که می دانیم EIGRP را می توان هم به روش کلاسیک و هم به روش مبتنی بر اسم (EIGRP Named mode) پیاده سازی نمود و با همین فرض پیاده سازی احراز هویت با توجه به نوع پیاده سازی EIGRP متفاوت خواهد بود. در این مقاله قصد داریم که هر دو روش پیاده سازی EIGRP و احراز هویت در آن را پوشش دهیم. به همین منظور یک توپولوژی ساده در نظر می گیریم که در آن دو روتر R1 و R2 با پروتکل مسیریابی EIGRP قصد برقراری ارتباط با یکدیگر را دارند. در این توپولوژی EIGRP روی روتر R1 با روش کلاسیک و در روتر R2 با روش Named mode پیاده سازی خواهند شد تا در ادامه احراز هویت در هر دو روش را مورد بررسی قرار گیرد.

 

روش های پیاده سازی EIGRP

با توجه به توضیحات فوق توپولوژی زیر مفروض می باشد.

توپولوژی

در روتر R1 پروتکل مسیریابی EIGRP را به روش کلاسیک پیکربندی می نماییم.


R1(config)#router eigrp 1
R1(config-router)#network 10.0.12.0 0.0.0.255
R1(config-router)#network 192.168.1.0 0.0.0.255

 

در روتر R2 پروتکل مسیریابی EIGRP را به روش مبتنی بر اسم (Named Mode) پیکربندی می نماییم. در سطر اول دستور NEW_EIGRP یک اسم می باشد که می توان با توجه به سیاست ها، هر اسمی را انتخاب نمود.


R2(config)#router eigrp NEW_EIGRP
R2(config-router)#address-family ipv4 unicast autonomous-system 1
R2(config-router-af)#network 10.0.12.0 0.0.0.255
R2(config-router-af)#network 172.16.1.0 0.0.0.255

 

اکنون پروتکل مسیریابی EIGRP بین دو روتر پیکربندی شده و همسایگی بین دو روتر برقرار گردیده است. جهت مشاهده همسایگی می توان از دستور زیر استفاده نمود.


R1#show ip eigrp neighbors

 

پیکربندی احراز هویت

جهت پیاده سازی احراز هویت در EIGRP، در این سناریو نوع اعمال دستورات متفاوت خواهد بود و دلیل این امر استفاده از دو روش پیاده سازی EIGRP می باشد. بنابراین دستورات احراز هویت در EIGRP به تفکیک زیر انجام خواهد گرفت .

 

پیکربندی روتر R1

در مرحله اول می بایست یک کلید (Key) ایجاد نموده و یک نام برای آن انتخاب کنیم  و سپس در خط دوم دستور یک ID برای کلید ایجاد شده انتخاب و سپس یک کلمه عبور به عنوان String در خط سوم دستور در نظر می گیریم.


R1(config)#key chain NEW_KEY
R1(config-keychain)#key 363
R1(config-keychain-key)#key-string CISCO

 

اکنون کلید ایجاد شده را می بایست به اینترفیسی که به روتر همسایه در EIGRP متصل می باشد، اعمال و نوع الگوریتم رمزنگاری را در خط دوم دستور مشخص نماییم.


R1(config-if)#ip authentication key-chain eigrp 1 NEW_KEY
R1(config-if)#ip authentication mode eigrp 1 md5

 

باید دقت داشت با اعمال این دستور همسایگی قطع خواهد شد چرا که دو روتر بر روی احراز هویت با یکدیگر اتفاق نظر نخواهند داشت. جهت برقراری مجدد همسایگی باید کلید و کلمه عبور را در روتر R2 نیز ایجاد و اعمال نماییم.

 

پیکربندی روتر R2

در روتر R2 پیکربندی احراز هویت به دلیل استفاده از EIGRP named mode کمی متفاوت از روتر R1 خواهد بود. در ابتدا کلید ها را مشابه مرحله قبل ایجاد می نماییم.


R2(config)#key chain NEW_KEY
R2(config-keychain)#key 363
R2(config-keychain-key)#key-string CISCO

 

در مرحله بعد کلید ایجاد شده را می بایست به اینترفیسی که به روتر همسایه در EIGRP متصل می باشد، اعمال و نوع الگوریتم رمزنگاری را نیز مشابه مرحله قبل به روش زیر مشخص می نماییم.


R2(config)#router eigrp NEW_EIGRP
R2(config-router)#address-family ipv4 unicast autonomous-system 1
R2(config-router-af)#af-interface gigabitEthernet 1/0
R2(config-router-af-interface)#authentication key-chain NEW_KEY
R2(config-router-af-interface)#authentication mode md5
Mar 20 12:50:12.539:UAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 10.0.12.1 (GigabitEthernet1/0) is up: new adjacency

 

همانطور که مشاهده می نمایید پس از انجام احراز هویت در روتر R2 همسایگی مجدد برقرار خواهد شد.

 

نظرات کاربران

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

Select the fields to be shown. Others will be hidden. Drag and drop to rearrange the order.
  • Image
  • SKU
  • Rating
  • Price
  • Stock
  • Availability
  • Add to cart
  • Description
  • Content
  • Weight
  • Dimensions
  • Additional information
Click outside to hide the comparison bar
Compare