Mohammadreza Soleimani 495 روز پیش verl
بازدید 1660 بدون دیدگاه

راه اندازی OSPF در سیسکو

راه اندازی OSPF در سیسکو، همانطور که می دانیم OSPF یک پروتکل مسیر یابی Link State است که به صورت استاندارد و قابل استفاده در تمامی Vendor ها می باشد. در این مقاله قصد داریم راه اندازی OSPF در روتر های سیسکو را مورد بررسی قرار دهیم. در ابتدا به تفاوت مسیریابی Dynamic و Static خواهیم پرداخت.

 

راه اندازی OSPF در سیسکو

فهرست مطالب

  1. تفاوت مسیریابی Dynamic و Static
  2. معرفی OSPF
  3. پیاده سازی

 

 

تفاوت مسیریابی Dynamic و Static

در محیط های سازمانی با مقیاس گسترده، استفاده از مسیریابی Static انتخابی بهینه محسوب نمی گردد، چرا که می بایست تمام مسیر ها به صورت  دستی ایجاد گردد. در چنین سناریو هایی غالبا از پروتکل های مسیریابی Dynamic استفاده خواهیم نمود که این پروتکل ها به صورت پویا مسیرها را ایجاد و بسته ها را در سطح شبکه توزیع خواهند نمود. در پروتکل های مسیریابی Dynamic روتر ها بر سر بهترین مسیر جهت رسیدن به مقصد ها با یکدیگر مذاکره می نمایند و با توجه به رفتار هر پروتکل مسیریابی، بهترین مسیر ها انتخاب و در جدول مسیریابی (Routing table) قرار خواهد گرفت. برخی از پروتکل های مسیریابی Dynamic (پویا) Distance Vector می باشند که در عمل بهترین گزینه نمی باشند چرا که بر اساس فاصله (تعداد Hop) بهترین مسیر را انتخاب می نمایند. به عنوان یکی از پروتکل های مسیر یابی Distance Vector می توان RIP را مثال زد. از RIP نمی توان به عنوان یک پروتکل مسیریابی هوشمند نام برد. به این دلیل که در محاسبه بهترین مسیر اولویت هایی مثل Cost هر لینک را در نظر نگرفته و صرفا تعداد Hop را معیار محاسبات خود در نظر خواهد گرفت و لینک های Serial و Gig تفاوتی در محاسبات بهترین مسیر در این پروتکل مسیریابی نخواهد داشت. اما شرایط در پروتکل های مسیریابی Link State متفاوت خواهد بود. به عنوان یکی از پروتکل های اصلی Link State می توان از OSPF نام برد. در پروتکل های مسیریابی Link State بهترین مسیر با توجه به اطلاعات و معیار های دیگری محاسبه خواهد شد.

 

معرفی OSPF

OSPF مخفف عبارت (Open Shortest Path First) می باشد که یک پروتکل مسیریابی Link State محسوب می گردد. در OSPF ما دستورات مربوطه را روی تمامی روتر ها اعمال می نماییم تا OSPF بر روی آن ها اجرا گردد. در این مرحله روتر ها شروع به مبادله اطلاعات با یکدیگر خواهند نمود که این اطلاعات توسط Link State Advertisement (LSA) ها بین روتر ها تبادل خواهند شد. هر روتر LSA های خود را ایجاد و در سطح شبکه ارسال می نماید و اطلاعاتی نظیر اینکه به صورت مستقیم به چه شبکه هایی متصل هستند و Cost جهت دسترسی به شبکه ها مختلف چقدر است را تحت LSA ایجاد می نماید. هر روتر با در اختیار داشتن کلیه این داده ها جهت تصمیم گیری برای کوتاه ترین مسیر (Shortest Path First) اقدام می نماید.

در OSPF به صورت پیش فرض می بایست یک Area با عنوان Area 0 وجود داشته باشد که به عنوان Backbone Area نیز از آن یاد می شود. چنانچه قصد داشته باشیم از چندین Area در شبکه سازمانی خود استفاده نماییم باید در نظر داشته باشیم که تمامی Area ها می بایست به صورت مستقیم به Area 0 ارتباط داشته باشند. رعایت این نکته در طراحی شبکه الزامی می باشد. اگرچه راهکار هایی جهت سناریو هایی که ارتباط مستقیم بین یک Area با Backbone Area وجود ندارد، در دسترس است اما همواره پیشنهاد می شود که از استاندارد ها پیروی نماییم.

 

 

پیاده سازی OSPF

به منظور پیاده سازی OSPF سناریویی ساده با در نظر گرفتن یک Area (Area 0) مفروض می باشد.

سناریو

 

در سناریو فوق قصد داریم تا به واسطه پروتکل مسیریابی OSPF شبکه 192.168.1.0/24 و 172.16.1.0/24 را به یکدیگر متصل نماییم و کامپیوتر های شبکه 192.168.1.0  قادر به برقراری ارتباط با کامپیوتر های شبکه 172.16.1.0 گردند.

 

تنظیمات روتر R1

در ابتدا اینترفیس های روتر R1 را آدرس دهی می نماییم. باید دقت داشته باشیم که اینترفیس های روتر R1 که به روتر های R2 و R3 متصل هستند به صورت Point to Point می باشند و subnetmask آنها /30 می باشد.

 


R1(config)#interface gigabitEthernet 1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface gigabitEthernet 2/0
R1(config-if)#ip address 10.1.1.5 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

 

در مرحله بعدی می بایست OSPF را در روتر فعال و سپس Network های روتر را به آن اضافه نماییم. در روتر R1 می توان Network ها را باتوجه به Wildcard Mask به صورت جداگانه یا هر دو Network را با یک دستور به OSPF اضافه نماییم. در اینجا ما هر دو Network را با یک دستور و Wildcard mask 0.0.0.255  در شبکه Advertise می نماییم.

 


R1(config)#router ospf 1
R1(config-router)#network 10.1.1.0 0.0.0.255 area 0

 

تنظیمات روتر R2

دستوراتی که در روتر R2 می بایست اجرا شوند به صورت زیر می باشد.


R2(config)#interface gigabitEthernet 1/0
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface gigabitEthernet 0/0
R2(config-if)#ip address 192.168.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router ospf 1
R2(config-router)#network 10.1.1.0 0.0.0.255 area 0
R2(config-router)#network 192.168.1.0 0.0.0.255 area 0
R2(config-router)#exit

 

تنظیمات روتر R3

همچنین تنظیمات روتر R3 با توجه به سناریو مورد نظر به صورت زیر خواهد بود.

 


R3(config)#interface gigabitEthernet 2/0
R3(config-if)#ip address 10.1.1.6 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface gigabitEthernet 0/0
R3(config-if)#ip address 176.16.1.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#network 10.1.1.0 0.0.0.255 area 0
R3(config-router)#network 172.16.1.1 0.0.0.255 area 0

با انجام تنظیمات فوق اتصال کلیه شبکه ها برقرار خواهد گردید. همچنین با دستور Show ip route می توان جدول Routing table را مشاهده نماییم.

جدول مسیریابی

 

مسیر هایی که با علامت O مشخص گردیده اند نشان دهنده مسیرهایی است که توسط پروتکل مسیریابی OSPF در سطح شبکه Advertise شده است. اکنون با توجه به پیکربندی انجام شده، دو شبکه متفاوت 192.168.1.0 و 172.16.1.0 قادر به برقراری ارتباط با یکدیگر خواهند بود.

 

نظرات کاربران

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

زمینه‌های نمایش داده شده را انتخاب نمایید. بقیه مخفی خواهند شد. برای تنظیم مجدد ترتیب، بکشید و رها کنید.
  • تصویر
  • شناسۀ محصول
  • امتیاز
  • قيمت
  • موجودی
  • دسترسی
  • افزودن به سبد خرید
  • توضیح
  • محتوا
  • وزن
  • اندازه
  • اطلاعات اضافی
برای مخفی‌کردن نوار مقایسه، بیرون را کلیک نمایید
مقایسه