Mohammadreza Soleimani 349 روز پیش verl
بازدید 1469 بدون دیدگاه

راه اندازی VRF در سیسکو

راه اندازی VRF در سیسکو، یکی از تکنولوژی هایی که می توانیم در روتر های سیسکو استفاده نماییم تا یک روتر را به چند جزء منطقی (Logical) تقسیم کنیم ، VRF می باشد. به واسطه VRF می توان یک جدول مسیریابی روتر را به چند قسمت تقسیم و  ایزوله نمود. در این مقاله قصد داریم تا نحوه راه اندازی VRF در روتر های سیسکو را مورد بررسی قرار دهیم.

 

راه اندازی VRF در سیسکو

فهرست مطالب

  1. مروری بر VRF
  2. پیاده سازی VRF

 

 

مروری بر VRF

VRF مخفف Virtual Route Forward می باشد که به واسطه آن می توان یک جدول مسیریابی روتر را به چند قسمت تقسیم و ترافیک ها را ایزوله نمود. برای درک بهتر می توان دو فرد را مورد مثال قرار داد که این دو فرد یک اتاق را با یکدیگر به اشتراک گذاشته اند. این دو فرد برای اینکه بتوانند وسایل خود را از یکدیگر جدا نمایند از یک دیوایدر در وسط اتاق استفاده نمایند تا به صورتی اتاق را به دو قسمت تقسیم نمایند. VRF در روتر نیز چنین مفهومی را ایجاد می نماید. در روتر یک جدول مسیریابی (Routing table) کلی داریم و به واسطه VRF می توانیم قسمت های مجزایی را در جدول مسیریابی ایجاد کنیم. در واقع VRF یک جدول مسیریابی منطقی می باشد که از جدول مسیریابی کلی روتر جدا و ایزوله می باشد. این مفهوم در Service Provider ها کاربرد خواهد داشت. باید در نظر داشت از VRF در موارد بسیاری از جمله MPLS Layer3 VPN می توان بهره برد.

پیاده سازی VRF شامل سه مرحله است:

  • ایجاد VRF
  • تخصیص اینترفیس هایی که در VRF مشارکت خواهند داشت
  • انجام تنظیمات مربوط به پروتکل مسیریابی در سناریو هایی که از پروتکل مسیریابی استفاده می گردد.

 

 

پیاده سازی VRF

جهت پیاده سازی VRF سناریو زیر مفروض می باشد.

سناریو

 

در این سناریو روتر R1 مسیرهایی را از روتر R2 و R3 در جدول مسیریابی خود خواهد داشت. با نگاه از زاویه یک Service provider ، این دو باید از یکدیگر جدا و ایزوله باشند. برای این سناریو در ابتدا می بایست دو VRF ایجاد نماییم. سپس در هر کدام از اینترفیس های روتر R1 می بایست VRF را مشخص نماییم. با انجام این کار هر مسیری که توسط روتر های R2 و R3 به روتر R1 ارسال گردد در درون VRF های مربوطه قرار گرفته و از جدول مسیریابی اصلی جدا و ایزوله می گردد. همچنین روتر R4 در این سناریو صرفا جهت ایجاد مسیر در جدول مسیریابی قرار گرفته و بین روتر R1 و R4 از پروتکل مسیریابی OSPF استفاده شده است. علاوه بر این مطابق دستورات بین روتر های R1 و R2 و R3 نیز از پروتکل مسیریابی OSPF استفاده خواهد شد.

 

تنظیمات در روتر R1

در مرحله اول VRF ها را ایجاد می نماییم. در دستورهای زیر first و Second تنها یک نام می باشد و بر اساس سیاست با به صورت دلخواه هر اسمی را می توان بر روی VRF قرار داد.

 


R1(config)#ip vrf first
R1(config-vrf)#exit
R1(config)#ip vrf second
R1(config-vrf)#exit

 

سپس می بایست اینترفیس ها را به VRF تخصیص دهیم. دقت داشته باشید با اعمال VRF بر روی اینترفیس ها ، آدرس های IP که بر روی اینترفیس ها قرار دادند حذف شده و پیغامی در این باره مشاهده می شود و نیاز است مجدد آدرس دهی بر روی اینترفیس انجام گیرد.

 


R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip vrf forwarding first
Interface GigabitEthernet0/0 IPv4 disabled and address(es) removed due to enabling VRF first
R1(config-if)#ip address 172.16.3.1 255.255.255.0
R1(config-if)#exit
R1(config)#interface gigabitEthernet 1/0
R1(config-if)#ip vrf forwarding second
Interface GigabitEthernet1/0 IPv4 disabled and address(es) removed due to enabling VRF second
R1(config-if)#ip address 172.16.4.1 255.255.255.0
R1(config-if)#exit

 

رد مرحله بعدی می بایست VRF را در پروتکل مسیر یابی OSPF که در شبکه مورد استفاده قرار گرفته اعمال نماییم. باید دقت داشت که می بایست بر روی روتر R1 چند Instance از OSPF ایجاد گردد. یک OSPF جهت پروتکل مسیریابی کلی شبکه و دو Instance از OSPF جهت دو VRF ایجاد شده. بنابراین دستورات این مرحله به صورت زیر اعمال خواهد گردید.

 


R1(config)#router ospf 1
R1(config-router)#network 10.1.1.0 0.0.0.255 area 0
R1(config-router)#exit
R1(config)#router ospf 2 vrf first
R1(config-router)#network 172.16.3.0 0.0.0.255 area 0
R1(config-router)#exit
R1(config)#router ospf 3 vrf second
R1(config-router)#network 172.16.4.0 0.0.0.255 area 0
R1(config-router)#exit

 

تنظیمات در روتر R2

روتر R2 در فرایند VRF هیچ نقشی نخواهد داشت و از وجود VRF در شبکه بی اطلاع خواهد بود. تنظیمات در روتر R2 تنها راه اندازی OSPF خواهد بود.

 


R2(config)#router ospf 1
R2(config-router)#network 172.16.3.0 0.0.0.255 area 0
R2(config-router)#exit

 

تنظیمات در روتر R3

تنظیمات در روتر R3 مشابه روتر R2 به صورت زیر خواهد بود.

 


R3(config)#router ospf 1
R3(config-router)#network 172.16.4.0 0.0.0.255 area 0
R3(config-router)#exit

 

در اینجا پیکربندی VRF در سناریو مورد نظر به پایان خواهد رسید. دقت داشته باشید که دستور Show ip route جدول مسیریابی، مسیرهای روتر های درون VRF را نمایش نخواهد داد. چنانچه قصد داشته باشیم که جدول مسیریابی های مربوط به VRF در این سناریو را مشاهد نماییم دستورهای زیر را وارد می نماییم.

 


R1#show ip route vrf first
R1#show ip route vrf second

 

همچنین جهت استفاده از دستور پینگ در روتر R1 به سمت شبکه های VRF دستور های زیر را وارد می نماییم.

 


R1#ping vrf first 172.16.3.33
R1#ping vrf second 172.16.4.44

 

 

نظرات کاربران

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

Select the fields to be shown. Others will be hidden. Drag and drop to rearrange the order.
  • Image
  • SKU
  • Rating
  • Price
  • Stock
  • Availability
  • Add to cart
  • Description
  • Content
  • Weight
  • Dimensions
  • Additional information
Click outside to hide the comparison bar
Compare