Mohammadreza Soleimani 234 روز پیش verl
بازدید 495 بدون دیدگاه

پیاده سازی Router On a Stick

پیاده سازی Router On a Stick، یکی از پیکربندی های شبکه می باشد که به از آن جهت دسترسی به قابلیت مسیر یابی ترافیک بین VLAN های مختلف استفاده می گردد. همانطور که می دانیم هر VLAN یک زیر شبکه یا Subnet جداگانه می باشد . به منظور مسیریابی بسته های IP به داخل و خارج از آن VLAN ها ، یا به طور دقیق تر، زیر شبکه هایی که روی هر یک از این VLAN ها قرار دارند نیاز به یک Router و داشتن آدرس IP در رنج هرکدام از Subnet های مورد نظر است. فرض کنید که یک سوئیچ در شبکه داریم که در آن تعدادی VLAN قرار دارد که هر کدام از این VLAN ها در Subnet های مجزا و ترافیک هایی ایزوله از هم قرار دارند. اگر قصد داشته باشیم ترتیبی دهیم که ترافیک برخی از VLAN های مد نظر ما به یکدیگر مسیریابی شوند و ارتباط بین آن ها برقرار گردد چه اقدامی باید نمود ؟ در چنین سناریویی ما با داشتن یک روتر با یک اینترفیس فیزیکی یا منطقی در یک شبکه می توانیم چنین کاری انجام دهیم به طوری که یک لینک از سوئیچ به سمت تک اینترفیس روتر ما برقرار گردد تا بتوان تنظیمات مد نظر را انجام نمود. به چنین سناریویی Router on a Stick یا one-Armed Router نیز گفته می شود. باید دقت داشت کلاینت هایی که در نظر داریم در چنین سناریویی دخیل باشند می بایست آدرس IP روتر را به عنوان Default Gateway بر روی آنها قرار دهیم که در جلوتر در بخش تنظیمات به طور دقیق این مطالب را شرح خواهیم داد.

 

پیاده سازی Router On a Stick

فهرست مطالب

  1. پیاده سازی Router On a Stick
  2. روش های اتصال هر VLAN به روتر
  3. توپولوژی
  4. سناریو
  5. تنظیمات سوئیچ
  6. تنظیمات روتر

 

روش های اتصال هر VLAN به روتر

سه گزینه برای اتصال روتر به هر زیر شبکه در VLAN وجود دارد :

  • استفاده از یک روتر و با بکار گیری یک لینک اترنت بین سوئیچ و روتر جهت هر VLAN . در این روش اگر قصد برقراری ارتباط بین شش VLAN را داشته باشیم باید 6 اتصال مجزا بین سوئچ و روتر برقرار نماییم. از این روش در اکثر مواقع استفاده نخواهد شد.
  • روش دوم استفاده از روتر و برقراری ارتباط VLAN Trunk با یک سوئچ می باشد.
  • روش سوم استفاده از یک سوئچ لایه سه می باشد.

 

توپولوژی

حالت دوم و سوم توپولوژی مشابهی را ارائه خواهد نمود که تنها تفاوت میان آنها استفاده از سوئچ لایه سه به جای روتر می باشد. در شکل زیر توپولوژی مورد نظر در مدل دوم و سوم را مشاهده می نماییم:

توپولوژی

Router on a Stick قابلیتی است که به ما این امکان را می دهد تا بسته ها را به زیر شبکه های مرتبط به VLAN با استفاده از یک روتر با اتصال 802.1Q Trunk هدایت نماییم. این پیکربندی با استفاده از VLAN Trunking کمک می نماید تا روتر با یک اینترفیس منطقی به هر VLAN با آن ارتباط برقرار نماید. Router on a Stick معمولا در سازمان هایی با ابعاد کوچک و متوسط که قصد دارند مسیریابی بین VLAN ها را داشته باشند پیاده سازی می گردد. این به معنای آن است که مسیریابی در شبکه داخلی بین VLAN ها انجام خواهد پذیرفت.

در چنین شرایطی از یک روتر استفاده خواهد شد تا بتوان به جای استفاده از سوئیچ لایه 3، بین VLAN های مختلف، برای سرورها و داده های کلاینت ها مسیریابی انجام شود.

در چنین سناریویی روتر چندین اینترفیس مجازی ایجاد می نماید که مرتبط با VLAN های مد نظر ما می باشد، سپس با تمام فریم هایی که با شناسه VLAN های مشخص برچسب گذاری شده اند به گونه ای برخورد می نماید که انگار این ورود و خروج فریم ها از این  زیر اینترفیس مجازی ( Subinterface ) صورت پذیرفته است.

زیر اینترفیس مجازی

با نگاهی به شکل بالا، متوجه خواهیم شد که دو اینترفیس فرعی به نام‌های G0/0.10 و G0/0.20 برای روتر ایجاد شده است تا بتواند به VLAN‌ های 10 و 20 مسیریابی نماید. سپس روتر با فریم های که با VLAN 10 برچسب گذاری شده به گونه ای رفتار می نماید که گویی از G0/0.10 وارد یا خارج شده اند، و فریم هایی که با VLAN 20 برچسب گذاری شده اند به گونه ای برخورد می نماید که گویی از G0/0.20 وارد یا خارج شده اند.

برچسب

 

سناریو Router on a Stick

توپولوژی شبکه ما شامل یک روتر و یک سوئیچ با VLAN 10 و VLAN 20 است که به هر کدام از این VLAN ها دو کامپیوتر متصل می باشد. سپس 802.1Q Trunking را روی روتر و سوئیچ پیکربندی می نماییم.

سناریو

تنظیمات سوئیچ

قصد داریم تا تنظیمات اولیه روی سوئیچ را انجام دهیم. در ابتدا VLAN10 و VLAN20 را ایجاد می نماییم. سپس اینترفیس VLAN های مد نظر را در سوئیچ فعال نموده و به آن ها یک آدرس IP در رنج های مشخص شده ( در VLAN10 از شبکه 10.1.10.0/24 و در VLAN20 از شبکه 10.1.20.0/24 استفاده شده). روی اینترفیس VLAN10 در سوئیچ آدرس 10.1.10.10/24 و روی اینترفیس VLAN20 آدرس 10.1.20.10 را قرار می دهیم این آدرس می تواند با توجه به تجهیزات و سیاست های مد نظر شما آدرس دهی شود و ما در اینجا صرفا آدرس 10 از هرکدام از رنج آدرس ها را استفاده نموده ایم. در قسمت Description ها در دستورات این نکته ذکر شود که ما از این Description ها استفاده نمودیم و همواره پیشنهاد می شود در محیط شبکه خود این کار را انجام دهید چرا که این توضیحات در آینده برای مدیریت و عیب یابی همواره بسیار کارآمد خواهد بود.


Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name IT-Dept
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name Sales-Dept
Switch(config-vlan)#exit
Switch(config)#interface vlan 10
Switch(config-if)#description **IT-Dept**
Switch(config-if)#ip address 10.1.10.10 255.255.255.0
Switch(config-if)# no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 20
do Switch(config-if)#description **Sales-Dept**
Switch(config-if)#ip address 10.1.20.20 255.255.255.0
Switch(config-if)# no shutdown
Switch(config-if)#end

دستور های بالا VLAN های 10 و 20 را با نام ها، توضیحات و آدرس IP های مربوطه ایجاد می نماید. اکنون می بایست پورت‌های Gi0/1 و Gi0/2 را به VLAN 10 و پورت‌های Gi0/3 و  Gi1/0را که طبق توپولوژی مشاهده می نماییم به VLAN 20 اختصاص می‌دهیم.


Switch(config)#interface gi 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface gi 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface gi 0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface gi 1/0
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#end

اکنون با استفاده از دستور Show vlan brief وضعیت vlan های ساخته شده و پورت های اکسس تخصیص داده شده به آن را بررسی می نماییم .

دستور Show vlan brief

اکنون به هرکدام از کامپیوتر ها یک IP اختصاص می‌دهیم تا نشان دهیم کامپیوتر های داخل هر VLAN با یکدیگر ارتباط دارند اما نمی‌توانند به کامپیوتر ‌های روی VLAN متفاوت دسترسی پیدا نمایند. برای کامپیوتر های VLAN10 آدرس های 10.1.10.11/24 و 10.1.10.12/24 و برای کامپیوتر های VLAN20 آدرس 10.1.20.11/24 و 10.1.20.12 را در نظر گرفته ایم.  اکنون از کامپیوتر اول روی VLAN10 کامپیوتر دیگر در همان VLAN یعنی 10.1.10.12 و کامیوتر در VLAN20 که در VLAN متفاوتی قرار دارد را پینگ می نماییم:

دستور پینگ

همانطور که در تصویر بالا مشاهده می نمایید کامپیوتر اول قادر است با کامپیوتری که در VLAN خود یعنی VLAN10 قرار دارد ارتباط برقرار نماید ولی با کامپیوتری که در VLAN20 قرار دارد نمی تواند ارتباط برقرار نماید. نکته اینکه ما در کامپیوتر های VLAN10 آدرس 10.1.10.1 و در کامپیوتر های VLAN20 آدرس 10.1.20.1 را به عنوان Default Gateway قرار داده ایم  که این آدرس ها در تنظیمات بخش روتر در پایین تر به عنوان آدرس در Subinterface های روتر قرار داده خواهد شد.

 

تنظیمات روتر

در ابتدا ما باید اینترفیسی که به سوئیچ متصل است را فعال نماییم که این کار به واسطه دستور زیر انجام خواهد گرفت :


Router#configure t
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface gi 0/0
Router(config-if)#no shutdown
LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up

اکنون با رفتن به زیر اینترفیس مورد نظر در Global Mode می توانیم زیر اینترفیس منحصر به فرد هر VLAN را در روتر ایجاد نماییم که برای مثال برای VLAN10 از دستور int gi 0/0.10 و برای VLAN20 از دستور int gi 0/0.20 استفاده می نماییم.

سپس باید از دستور encapsulation dot1q VLAN_ID استفاده تماییم که به جای VLAN_ID باید شماره VLAN مورد نظر خود را قرار دهیم.

در مرحله بعدی باید به این زیر اینترفیس ایجاد شده آدرس IP تخصیص دهیم. که برای زیر اینترفیس VLAN10 آدرس 10.1.10.1/24 و برای زیر اینترفیس VLAN20 آدرس 10.1.20.1/24 را قرار خواهیم داد.


Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface gi 0/0.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 10.1.10.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface g 0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 10.1.20.1 255.255.255.0
Router(config-subif)#end

اکنون می توانیم با دستور show ip interface brief می توان وضعیت اینترفیس های ایجاد شده و آدرس های IP آن ها را مشاهده نمود :

دستور Show ip interface brief

در مرحله آخر می بایست پورتی که از سوئیچ به روتر متصل است را در سوئیچ به حالت Trunk متصل کنیم تا بسته های برچسب خورده از سوئیچ را به سمت روتر ارسال نماید. دقت کنید در حالت پیش فرض بسته های برچسب خورده ارسال نمی گردند و این کار پس Trunk شدن انجام خواهد پذیرفت. در این سناریو اینترفیسی که باید این کار روی آن انجام گیرد اینترفیس Gi0/0 سوئیچ می باشد. به همین منظور دستور زیر می بایست در سوئیچ اجرا گردد :


Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface gi 0/0
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk

در مرحله آخر باید بررسی کنیم که کلیه عملیاتی که انجام داده ایم به درستی انجام گرفته یا خیر. برای این کار مجدد می بایست از کامپیوتر در VLAN10 کامپیوتری در VLAN20 را پینگ کنیم . این بار باید ارتباط برقرار شده باشد و پاسخ پینگ دریافت شود و ارتباط بین VLAN ها برقرار گردیده باشد.

 

تست با ابزار پینگ

 

همانطور که در تصویر بالا مشاهده می نمایید از PC1 که در VLAN10 قرار دارد هر دو کامپیوتر در VLAN20 قابل دسترس است و ارتباط دو VLAN10 و VLAN20 بر قرار گردیده. همچنین ttl از 64 که قبلا مشاهده می نمودیم به 63 تغییر یافته که این نشان دهنده این است که یک Routing در مسیر انجام پذیرفته و یک واحد از ttl به همین ترتیب کم شده است.

 

در این مقاله به طور مختصر در مورد تکنولوژی و فرآیند پشت Router on a Stick بحث و نشان دادیم که چگونه می توانید یک لینک Trunk 802.1Q بین روتر و سوئیچ سیسکو را پیکربندی نمایید. پیکربندی Router on a stick بیشتر در محیط‌هایی انجام می گیرد  که در آن سوئیچینگ لایه 3 وجود ندارد، مسیریابی بین VLAN با استفاده از یک روتر و  یک اینترفیس ارتباطی همواره مقرون به صرفه تر از استفاده از سوئیچ لایه 3 می باشد.

نظرات کاربران

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

Select the fields to be shown. Others will be hidden. Drag and drop to rearrange the order.
  • Image
  • SKU
  • Rating
  • Price
  • Stock
  • Availability
  • Add to cart
  • Description
  • Content
  • Weight
  • Dimensions
  • Additional information
  • Attributes
  • Custom attributes
  • Custom fields
Click outside to hide the comparison bar
Compare
Compare ×
Let's Compare! Continue shopping